Jump to content




Photo

No Pinmame table working now !


  • Please log in to reply
6 replies to this topic

#1 jukecade

jukecade

    Hobbyist

  • Members
  • PipPip
  • 17 posts

  • Flag: ---------

  • Favorite Pinball: Red Dwarf

Posted 16 December 2011 - 11:37 PM

Hi All

A while a go I had mixture of VP8/9 & Pinmame tables installed and everything seems to be ok. I then downloaded the Space1999 tables and found them not to be working. I thought it was the tables but I find tables like Austin Powers have stopped working. I think Pinmame has got screwed up so I unintsllaed Pinmame and installed the latest version (& VP9,12), set the paths, etc but they still dont work. I get alsorts of errors such as:

Austin Powers Errors (Running under VP8):
1. vb script: Cant load VPinMAME, ActiveX component cannot create object
2. VPinMame ver 0120000 required
3. Line 132: Object required (Controller)

Alien Poker Errors (Running under VP8):
1. Unable to open S6.VBS Ensure the object is in the folder as this table (I checked and it is!!!!!!)
ActiveX component cannot create object
2. Cant load VPinMAME, ActiveX component cannot create object
3. VPinMame ver 0130000 required
4. S6.VBS ver1.2 or higher required
5. Line 35: "Lampcallback" varibale not defined
6. Cant start game apolk_l6
Invalid or unqualified reference

VP9:Space1999_FS_B2S errors
1. Line 0 ActiveX component cannot create object "Wscript.shell" (line 0 is ' ********************************** in script - removing line just moves the error to the next line)
2. Line 0: Object required "objRegistery"

OK now the technical bit. Im running a 2GB memory I3core laptop under Windows 7 starter, NVidia 310m. I have .net4 installed and all the latest W7 updates. FP runs fine, MAME runs fine. Only seems to be a Vpinmame problem

Thank you, Thank you


However, table such as American Idol work fine.

Please help - I'm tearing my hair out trying to get these tables working again



#2 blur

blur

    Pinball Fan

  • VIP
  • 1,477 posts

  • Flag: Croatia

  • Favorite Pinball: The Amazing Spiderman



Posted 16 December 2011 - 11:52 PM

you have to install and setup vpinmame, it is not enough to install just vp, check install guide

Edited by blur, 16 December 2011 - 11:53 PM.


#3 jukecade

jukecade

    Hobbyist

  • Members
  • PipPip
  • 17 posts

  • Flag: ---------

  • Favorite Pinball: Red Dwarf

Posted 17 December 2011 - 03:44 AM

QUOTE (blur @ Dec 16 2011, 11:52 PM) <{POST_SNAPBACK}>
you have to install and setup vpinmame, it is not enough to install just vp, check install guide


Maybe I didnt make myself clear - I have installed both Visual Pinball and VPinMAME. Latest versions.....

These errors shown on both older and the most recent versions.

Thanks

#4 rosve

rosve

    :)

  • VIP
  • 1,179 posts
  • Location:Always travelling around the world

  • Flag: Sweden

  • Favorite Pinball: Funhouse, Faces, Starship Troopers



Posted 17 December 2011 - 09:28 AM

QUOTE (jukecade @ Dec 17 2011, 04:44 AM) <{POST_SNAPBACK}>
QUOTE (blur @ Dec 16 2011, 11:52 PM) <{POST_SNAPBACK}>
you have to install and setup vpinmame, it is not enough to install just vp, check install guide


Maybe I didnt make myself clear - I have installed both Visual Pinball and VPinMAME. Latest versions.....

These errors shown on both older and the most recent versions.

Thanks


You asked the same question in the Space 1999 ws thread. Here is a copy of my reply:

Found this on Google

"I suspect windows script host in your case. Try to download latest windows script host and install. You can also try to register the following file wshom.ocx
Start --> Run --> Type "regsvr32.exe wshom.ocx" [without quotes] --> press enter

If this doesn't fix your issue then try to download windows script host latest version and install. That should solve the issue.
"



#5 blur

blur

    Pinball Fan

  • VIP
  • 1,477 posts

  • Flag: Croatia

  • Favorite Pinball: The Amazing Spiderman



Posted 17 December 2011 - 04:22 PM

check your vbs scripts - looks like this table has downgraded some of the scripts to older version.

you can download complete scripts pack, latest version

#6 jukecade

jukecade

    Hobbyist

  • Members
  • PipPip
  • 17 posts

  • Flag: ---------

  • Favorite Pinball: Red Dwarf

Posted 18 December 2011 - 10:55 PM

QUOTE (rosve @ Dec 17 2011, 09:28 AM) <{POST_SNAPBACK}>
QUOTE (jukecade @ Dec 17 2011, 04:44 AM) <{POST_SNAPBACK}>
QUOTE (blur @ Dec 16 2011, 11:52 PM) <{POST_SNAPBACK}>
you have to install and setup vpinmame, it is not enough to install just vp, check install guide


Maybe I didnt make myself clear - I have installed both Visual Pinball and VPinMAME. Latest versions.....

These errors shown on both older and the most recent versions.

Thanks


You asked the same question in the Space 1999 ws thread. Here is a copy of my reply:

Found this on Google

"I suspect windows script host in your case. Try to download latest windows script host and install. You can also try to register the following file wshom.ocx
Start --> Run --> Type "regsvr32.exe wshom.ocx" [without quotes] --> press enter

If this doesn't fix your issue then try to download windows script host latest version and install. That should solve the issue.
"



Hi
I did try this but I get an error:

The Module "wshom.ocx" was loaded but the call to DllRegisterServer failed with error 0x80040201

I tried searching for this code but all the MS website seems to say about this code is for things like Outlook which I dont have installed or use. The wshom.ocx doesnt seem to be available from the MS website either but is availabel from 3rd party one which I dont trust aas they all try nto force you in running a hoax virus check befor you can download.

I tried this script:
Option Explicit

Dim objFSO, strFolder

Call MsgBox("WSH Version: " & Wscript.Version _
& vbCrLF & "VBScript major version: " & ScriptEngineMajorVersion _
& vbCrLf & "VBScript minor version: " & ScriptEngineMinorVersion)

strFolder = "C:\Windows"

Set objFSO = CreateObject("Scripting.FileSystemObject")
If (objFSO.FolderExists(strFolder) = True) Then
Call MsgBox("Folder " & strFolder & " exists" _
& vbCrLf & "and the FileSystemObject works fine")
Else
Call MsgBox("Folder " & strFolder & " does NOT exists" _
& vbCrLf & "but the FileSystemObject works fine")
End If
saved as version.vbs and run via run cscript c:\Version.vbs and its reports all ok
WSH Version 5.9, VBScript major version5, VBScript minor version: 8
Folder c:\windows exists and the FileSystemObject works fine


QUOTE
check your vbs scripts - looks like this table has downgraded some of the scripts to older version.

When i did a reinstall I made sure none of my table scripts were overwritten so I dont think this is the problem....

Thanks all for your help. I hope someone can fix this for me

Happy Holidays Everyone!

Edited by jukecade, 18 December 2011 - 11:15 PM.


#7 jukecade

jukecade

    Hobbyist

  • Members
  • PipPip
  • 17 posts

  • Flag: ---------

  • Favorite Pinball: Red Dwarf

Posted 22 December 2011 - 11:32 PM

Well

I finally go Pinmame back working. Not too sure what happened or why but all I did was give vpinmame.exe and the .dll full control access rights, run as administrator and run as xp with service pack 3 compatibility mode but now when running the tables again the first time I have to click the Yes/No message box that gets displayed. I've already done this before and I havent overwritten any nvram/other files so not too sure why this is happening.

I have two more questions:

1) Sometime when exiting VP/VPM via Maximus Frontend they close with an error and not cleanly. Which is a pain cos I have to have the mouse handy to clock Close program.

2) I installed the VPM .dll for cabinets to try to stop the message boxes from showing at the front but still on Elvis & Hotwheels I get a a message saying something about the sound not working properly. How do I turn off ALL messages?

Thanks everyone

Happy Christmas




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users