Jump to content




Photo
* * * * * 38 votes

The VP 10.7 beta thread


  • Please log in to reply
3620 replies to this topic

#3541 VonKrafte

VonKrafte

    Neophyte

  • Members
  • Pip
  • 8 posts

  • Flag: United States of America

  • Favorite Pinball: Whatever I'm streaming on Twitch as VonKrafte

Posted 13 September 2022 - 02:00 AM

Had the exact same experience on this end (flippers and random playfield elements looking fine in 10.7.1 but becoming invisible in 10.7.2).

 

probably attributable to the fact that I'm running on an old-ass laptop but I figured I'd mention it so you know it's happened to more than one person. :)

 

 

10.7.2 made my DE Simpsons playfield disappear, messed up my DE Indy Rom, & made my Haunted House flippers disappear.

There were probably other negative effects as well, I gave up after those table tests...

After all that I went back to 10.7.1... (with allot of effort).

 

Not sure why you are having those issues
but to go back to 10.7.1 you only have to drop the vpinballX.exe in
no script or dll changes presently



#3542 BrandonLaw

BrandonLaw

    Enthusiast

  • Members
  • PipPipPip
  • 483 posts

  • Flag: United States of America

  • Favorite Pinball: Tron

Posted 13 September 2022 - 09:55 AM

Still getting random non-opens on 283.  More 'non' than open.  Tried to find out if another program like Chrome is hosing it with no luck.

 

 

 

Thalamus' still opens with no issues.


"S...O...S"  /repeat


#3543 wiesshund

wiesshund

    VPF Veteran

  • Members
  • PipPipPipPipPipPip
  • 8,288 posts

  • Flag: United States of America

  • Favorite Pinball: How many can i have?

Posted 13 September 2022 - 06:13 PM

 

Had the exact same experience on this end (flippers and random playfield elements looking fine in 10.7.1 but becoming invisible in 10.7.2).

 

probably attributable to the fact that I'm running on an old-ass laptop but I figured I'd mention it so you know it's happened to more than one person. :)

 

 

 

 

Old ass Dell Latitude E5430 here, and cannot replicate

Intel hd4000 graphics


It counts as a cabinet, right?

eVi4DPF.png


#3544 GCS

GCS

    Enthusiast

  • Members
  • PipPipPip
  • 57 posts

  • Flag: ---------

  • Favorite Pinball: Gorgar

Posted 13 September 2022 - 07:02 PM


 

Had the exact same experience on this end (flippers and random playfield elements looking fine in 10.7.1 but becoming invisible in 10.7.2).

 

probably attributable to the fact that I'm running on an old-ass laptop but I figured I'd mention it so you know it's happened to more than one person. :)

 

 

 


Same disappearing backgrounds here with 10.7.2

 

Win10/i7@3.4/AMD RX470 with latest drivers/8GB RAM


Edited by GCS, 13 September 2022 - 07:03 PM.


#3545 LoadedWeapon

LoadedWeapon

    The Night Owl..

  • Members
  • PipPipPipPipPip
  • 2,531 posts
  • Location:South Carolina USA

  • Flag: United States of America

  • Favorite Pinball: Star Trek TNG



Posted 13 September 2022 - 08:51 PM

yea i7 and nvidia 1070 super and some tables like tales from the crypt wont even play they just load pupack and playfield vanishes.... 



#3546 wiesshund

wiesshund

    VPF Veteran

  • Members
  • PipPipPipPipPipPip
  • 8,288 posts

  • Flag: United States of America

  • Favorite Pinball: How many can i have?

Posted 13 September 2022 - 10:15 PM

yea i7 and nvidia 1070 super and some tables like tales from the crypt wont even play they just load pupack and playfield vanishes.... 

is this only on a PUP table?

If you disable PUP
and launch the table
does table itself work?


It counts as a cabinet, right?

eVi4DPF.png


#3547 Cliffy

Cliffy

    Enthusiast

  • Members
  • PipPipPip
  • 51 posts

  • Flag: United States of America

  • Favorite Pinball: King of Diamonds

Posted 13 September 2022 - 10:52 PM

Man all this disappearing stuff just has not happened to me. I'm on vpx 10.7.2 rev 283 32 bit, I7 with nvidia 1060 6gb, newest vpinmame 3.5-SC, latest july runtimes installed. I'm only in desktop mode but I try everything these guys are playing- some with pups, many without- and no vanishing stuff whatsoever (thank goodness, knock wood!) 

Baffling-



#3548 LoadedWeapon

LoadedWeapon

    The Night Owl..

  • Members
  • PipPipPipPipPip
  • 2,531 posts
  • Location:South Carolina USA

  • Flag: United States of America

  • Favorite Pinball: Star Trek TNG



Posted 13 September 2022 - 11:10 PM

same...

https://youtube.com/...Y?feature=share



#3549 wiesshund

wiesshund

    VPF Veteran

  • Members
  • PipPipPipPipPipPip
  • 8,288 posts

  • Flag: United States of America

  • Favorite Pinball: How many can i have?

Posted 13 September 2022 - 11:17 PM

 

if you alt tab, do you even see the vp player at all?


It counts as a cabinet, right?

eVi4DPF.png


#3550 LoadedWeapon

LoadedWeapon

    The Night Owl..

  • Members
  • PipPipPipPipPip
  • 2,531 posts
  • Location:South Carolina USA

  • Flag: United States of America

  • Favorite Pinball: Star Trek TNG



Posted 13 September 2022 - 11:22 PM

No it crashes or closes..
No crash log

Edited by LoadedWeapon, 13 September 2022 - 11:26 PM.


#3551 Cliffy

Cliffy

    Enthusiast

  • Members
  • PipPipPip
  • 51 posts

  • Flag: United States of America

  • Favorite Pinball: King of Diamonds

Posted 14 September 2022 - 12:39 AM

Antivirus maybe? Try turning it off for 10 minutes or so? You should have a DmdDevice.log in your vpinmame folder. It can reveal a LOT of info



#3552 wiesshund

wiesshund

    VPF Veteran

  • Members
  • PipPipPipPipPipPip
  • 8,288 posts

  • Flag: United States of America

  • Favorite Pinball: How many can i have?

Posted 14 September 2022 - 01:34 AM

No it crashes or closes..
No crash log

 

Any VPXes orphaned in task manager?

 

Also, try the EXE from the debug build and have it log
in case it shows up anything useful


Edited by wiesshund, 14 September 2022 - 01:35 AM.

It counts as a cabinet, right?

eVi4DPF.png


#3553 Pinballman

Pinballman

    Enthusiast

  • Gold Supporter
  • 248 posts

  • Flag: ---------

  • Favorite Pinball: Wizard of Oz

Posted 14 September 2022 - 03:20 AM

Man all this disappearing stuff just has not happened to me. I'm on vpx 10.7.2 rev 283 32 bit, I7 with nvidia 1060 6gb, newest vpinmame 3.5-SC, latest july runtimes installed. I'm only in desktop mode but I try everything these guys are playing- some with pups, many without- and no vanishing stuff whatsoever (thank goodness, knock wood!) 

Baffling-

Same experience here as Cliffy - no issues with 283 or the latest 285 I just tried. I too am in desktop mode. Windows 10 with Intel® Core™ i7-10750H CPU @ 2.60GHz, Nvidia RTX 2070 Super GPU.



#3554 JoeyKush

JoeyKush

    Neophyte

  • Members
  • Pip
  • 6 posts

  • Flag: ---------

  • Favorite Pinball: Spring Break

Posted 14 September 2022 - 06:37 AM

Do you have to uninstall anything before updating?

#3555 wiesshund

wiesshund

    VPF Veteran

  • Members
  • PipPipPipPipPipPip
  • 8,288 posts

  • Flag: United States of America

  • Favorite Pinball: How many can i have?

Posted 14 September 2022 - 12:27 PM

Do you have to uninstall anything before updating?

to test the betas?
no.
In fact if you are already using release 1.7.0 then all you need to do to test the betas is
pull just the VisualpinballX.exe out of the zip
rename your existing one, in case you need to go back, to like VisualpinballX 10.7.0.exe
and drop the new exe in your vpx folder

 

If you are still using an older version, then use the whole zip to make sure your scripts folder is up to date


It counts as a cabinet, right?

eVi4DPF.png


#3556 count220

count220

    Neophyte

  • Members
  • Pip
  • 3 posts

  • Flag: ---------

  • Favorite Pinball: medieval madness

Posted 15 September 2022 - 05:23 PM

I'm also running into the issue with VPX not completely loading on most launches. Happens about 50% of the time as of rev281.

 

It's not crashing, it's just not showing up. Every failed launch remains in memory, which may explain the lack of crash log. LMK if you need additional info to help you find the culprit.

 

iUGugzf.png


Edited by count220, 15 September 2022 - 05:25 PM.


#3557 Thalamus

Thalamus

    Pinball Wizard

  • Platinum Supporter
  • 4,726 posts

  • Flag: Norway

  • Favorite Pinball: GOT, Alien Star, LOTR, TOM

Posted 15 September 2022 - 07:07 PM

Yepp. It is kind of not crashing, weird, and probably a small out of hands fault by the automatic compile via github. I'm sure at some point, ether by changing build config, or a microsoft update to github build process will fix it. For everyone that is still having these crashes. I'll proved on a semi-regular basis updated compiles, recommended and targeted only for you that actually is hit by this bug. My latest build is still 283 from a couple of day ago, but, latest should be mostly compiler cleanups anyway. Not essential to features : https://www.dropbox....nballX.exe?dl=0

 

Again, if you DON'T have issues like @count220 - use official. IF for some very odd and I don't expect this to happen. Any offical 10.7.2 or maybe it will be 10.7.3 ? Will be build by toxie on his own machine instead of the odd issue we're now seeing for a few.


From now on. I won't help anyone here at VPF. Please ask Noah why that is.


#3558 pinballdownloadpleas

pinballdownloadpleas

    Neophyte

  • Members
  • Pip
  • 6 posts

  • Flag: ---------

  • Favorite Pinball: star trek

Posted 15 September 2022 - 11:14 PM

Here's some info, i also get a lot of crashing, VPX will only open 1 in 5 times i run it.
Process monitor compared between a failed run and a success run. Not sure it will help but here it is, i marked the area so you can see what the next few steps are on a success run and compare it to a failed run?

 

chZyPsG.jpeg

 

 

A6kLz9C.jpeg

 

 

Direct link for these images as they are 4k and need to be viewed at full scale to read properly.

https://i.imgur.com/chZyPsG.jpeg

https://i.imgur.com/A6kLz9C.jpeg

 

 

Also to note, if i try to debug it with x32dbg, it will launch every single time. I can't get it to not launch when running it through the debugger and stepping through. Running from explorer only actually runs 1/5 times i try. This is on version 281 32bit.

 

Windows 10 latest version all updates, ryzen 5950 cpu, nvidia 3080 gtx gpu latest nvidia drivers.

Run as admin makes no difference.



#3559 Andypc

Andypc

    Enthusiast

  • Gold Supporter
  • 166 posts
  • Location:London, United Kingdom

  • Flag: United Kingdom

  • Favorite Pinball: Medieval Madness / Lethal Weapon 3

  • PS3 Gamer Tag: Andypc
  • 360 Gamer Tag: Andypc

Posted 15 September 2022 - 11:49 PM

I am getting a problem I have never seen before on a few recent tables. VPW's Jokerz, Tron and Bigus's Iron Man. I am getting ball stutter very early in the game the first time a certain event takes place. i.e. first time a spinner or magnet is hit I am getting bad stutter. After that everything is rock solid. I have just upgraded my graphics cards and yet the issue remains. I have great frame rates on these tables, so the issue is caused by the first time certain events happen on the table. This seems to be a new issue on recent tables.



#3560 ashleyb

ashleyb

    Enthusiast

  • Members
  • PipPipPip
  • 69 posts

  • Flag: United Kingdom

  • Favorite Pinball: White Water

Posted 16 September 2022 - 10:00 AM

https://www.vpforums...952#entry506440

Anyone with issues with the latest beta tried uninstalling GeForce experience if they have it installed? See the above post, sounds like he was having similar symptoms and uninstalling it helped.

Edited by ashleyb, 16 September 2022 - 10:04 AM.